09. Cubo: Conceptos y manejo

La herramienta CUBO cuenta con 4 pestañas superiores:

General: Donde se ven los cubos que existen y accedes a ellos. El cubo es el archivo que contiene los datos que se generan desde PROSCAI y que serán analizados. Se puede tener diferentes cubos.

Filtros: Se muestran todos los elementos que conforman la información: “Dimensiones” y “Elementos” (conocidos en PROSCAI como clasificadores principalmente, aunque pueden utilizarse otros elementos), así como una variedad de botones con los cuales podrás manejar y filtrar tus datos.

Tabla: Una vez filtrada la información (puesta en rangos para analizar), se presenta la “Tabla” de datos, donde podrás seguir filtrando e intercambiando las “Dimensiones” según la información a analizar.

Gráfica: Lugar donde aparecen en forma de gráfica los “valores” de la “Tabla”.

Te permite variar los formatos, la visión de las gráficas, los colores, así como las métricas que deseas valorar.

Desde esta vista puedes identificar áreas muy rápidamente, para nuevos análisis.

1. Al seleccionar el CUBO VENTAS por detalle, se seleccionó la vista de la pestaña Tabla.

La Tabla está conformada por “celdas”, cada celda (1) contiene un “valor” específico que surge de la información contenida en la base de datos.

Cuando hay una celda con fondo amarillo, significa que estás viendo cifras en totales.

En la parte superior se encuentran las “dimensiones” (2) que son los campos extraídos de la base de datos. Cuando se encuentran arriba, podríamos decir que están en “la banca” listas para emplearlas cuando las necesitemos.

Cada dimensión comprende un conjunto de “elementos”, en este ejemplo podemos ver que la Dimensión Documento se encuentra abajo y desplegada y que el número de cada ticket es un elemento. Las dimensiones se pueden colocar de forma horizontal formando “renglones” o de forma vertical conformando “columnas”.

Si quieres ver qué elementos componen cada dimensión, solo presiona sobre la flecha de esa dimensión para que despliegue los datos.

Para manejar las “dimensiones” y sus “elementos” cuentas con una pequeña barra de herramientas que permite considerar todos los elementos, quitar algunos, invertir la selección, etc.

 

 

Activa o selecciona todas las casillas de los elementos.

 

Apaga todas las casillas

 

Invierte los que tiene, es decir, si hay casillas activas y apagadas, este botón invierte esa información.

 

Funciona como la tecla Enter, es OK.

 

Cierra la ventana desplegada.


Si alguna de las “dimensiones” cambia a color negro, significa que hay elementos de esa dimensión que se eliminaron o inhibieron para el análisis.

Las “Métricas” (3) son aquellos rangos que se pueden medir: Importe bruto, Importe Neto, Costos, Piezas subtotal, utilidad, etc. también contenidos en la base de datos.

Si estás trabajando con varias “dimensiones” (4), tienes la facilidad de ordenarlas según tus necesidades.

Si al estar en esta ventana quieres realizar un análisis más detallado, selecciona un rango de celdas, y filtra (5) la información haciendo clic en los botones “Dejar Selección”, ”Quitar Selección” e ”Invertir”. También puedes Imprimir o Exportar a Excel tu información.

Para sacar de “la banca” alguna dimensión, es necesario posicionarse sobre ella, bajarla ligeramente y colocarla sobre la horizontal o la vertical, se ilumina una franja verde.

También se puede variar el orden o la posición de las dimensiones, de forma que las celdas se relacionarán con base a las
dimensiones que traigas “en juego”.

Adicionalmente podrás expandir o contraer las dimensiones para ver únicamente subtotales, utilizando el botón -  + de la primera dimensión.

Gráficas

Para consultar las gráficas, dejemos las tablas a analizar.

1. En la pestaña Tabla coloca dos Dimensiones, para este ejemplo será Tienda y Año.  Se activaron las métricas.

2. Ahora ve a la pestaña Gráfica.

Los botones de Proporciones (1) permiten ajustar visualmente la proporción de la gráfica.

Los botones Posición de Texto mueve los textos para colocarlos en la mejor posición de lectura, según la posición de la gráfica.

Los botones Desde Arriba, Desde Enfrente y Desde Derecha (2) varían la posición de la gráfica y presentan diferentes formas de verla.

Al hacer clic, aparece el cursor en forma de “manita” con la cual también se gira la posición de la gráfica.

Al observar la gráfica podrás darte cuenta de que existen diferencias en la escala manejada. Si deseas ajustarlas, activa la opción Misma escala (3) y observa cómo automáticamente se nivela.

También puedes decidir si quitas o eliminas en la vista, las “Paredes“ de la gráfica.

Se ha señalado desde el inicio, que el CUBO es una herramienta de análisis multidimensional, ya que simultáneamente son muchos datos los que se puede poner en la tabla y se reflejan en la gráfica, permitiéndote variar tanto las métricas como las dimensiones.

Al momento de generar las gráficas, el sistema siempre selecciona automáticamente las dos primeras métricas que aparecen en la Tabla, en este ejemplo son Importe Bruto e Importe Neto.

Existe la posibilidad de analizar simultáneamente las dos informaciones en conjunto o por separado, para tal efecto active o desactive los campos de Gráfica 1 y Gráfica 2 (4).

Ambas gráficas con la misma escala se ven así:

Al elegir una gráfica, empiezan a resaltar los datos.

El Color basado en (5) permite cambiar el color de la información según la métrica o dimensión que deseas. Una forma fácil de comprenderlo es seleccionando AÑO, ya que solamente existen dos elementos y se representan en dos colores.

3. Elija ahora el color basado en PZAS.

Los colores adquieren significado: lo más claro es lo más pequeño, lo que menos llama la atención; y lo más oscuro es lo más significativo o como en este caso, lo que más representa de ventas, tanto de importe como de piezas.

4. Si generas la gráfica en el color basado en tiendas, obtendrás otra vista.

También puede variar los Tipos de Gráfica (6) y elegir la que más convenga.

Si combinas esta opción con las vistas Desde Arriba, Desde Enfrente o Desde Derecha, obtendrás otros resultados.

La barra de herramientas (7) es muy sencilla de manejar.

a

Vista preliminar de impresión

g

Mueve la gráfica de arriba a abajo por pasos

b

Manda a imprimir a la predeterminada

h

Vista en perspectiva de la gráfica

c

Gira la gráfica sobre su eje vertical

i

Cursor sin movimiento de gráfica

d

Gira la gráfica sobre su eje horizontal

j

Cursor con movimiento de gráfica

e

Aumenta y reduce el tamaño de la gráfica por pasos

k

Aumenta o reduce el tamaño de la gráfica

f

Mueve la gráfica a derecha e izquierda por pasos

l

Coloca la gráfica donde la desees.

Utiliza las diferentes herramientas para conocer el alcance de cada una.

Coloca la gráfica en Barras con el color basado en el Importe Neto, y con la misma escala.

En la parte superior de todas las pestañas existe el campo llamado Vista (8). Esto permite crear y guardar “fotografías” de los datos filtrados para posteriormente regresar a ellos sin necesidad de volver a filtrar todo.

5. Haz clic en el botón Nueva, captura el nombre Vista de prueba 1 y guarda.

Puedes guardar todas las vistas para regresar a ellas más tarde.

6. Elige ahora otra vista, para este ejemplo será Vista Demo para que veas los efectos.

7. Regrese nuevamente a la vista que acabas de generar.

Escribe las observaciones o comentarios que tengas al respecto de esta vista en la zona inferior de la ventana (9) y oprime el botón Guardar para que el mensaje quede registrado.

Cuantas veces llames esta vista, ese mensaje también aparecerá.

Filtros

Desde la pestaña Filtros también puedes preparar la información para graficarla.

1. Selecciona la pestaña Filtros. Todos los elementos de todas las dimensiones se muestran activas.

Existen otros botones de filtros que se irán explicando, una “barra de selección” de porcentajes rápido, las dimensiones y un color para las celdas:

Si todos los elementos de una dimensión están activos, se sugiere que la dimensión no esté filtrada y todos sus elementos se consideran para la tabla y la gráfica.

Si se encuentran Celdas desactivas, indica que la dimensión se encuentra filtrada en sus elementos o valores.

Las celdas de color representan los valores que corresponden al porcentaje mayor de la dimensión filtrada, por ejemplo, el 80% de las ventas.

Las celdas sin color representan el porcentaje restante o menor de lo filtrado, por ejemplo, el 20 % de las ventas.

2. Cuando se selecciona una columna, ésta se pinta de verde.

3. Al hacer clic en el botón  80/20 se modifican los valores de la columna. Observa que para este ejemplo se desactivaron varios almacenes.

Esto significa que los almacenes en color venden el 80 % del total de las ventas y los almacenes sin color venden el 20% restante.

4. Observa también los recuadros localizados debajo de los filtros.

Del lado izquierdo aparecen las cifras de la primera métrica, que para este ejemplo es el Precio. Las tiendas que quedaron activas representan el 83% (5,575,726349) del total de las ventas.

Del lado derecho se indica que, de las 19 tiendas existentes, 12 se encuentran activas y representan el 63.2 % de las ventas. Las cantidades representan los rangos mínimo y máximo de venta de esas 12 tiendas.

Por lo tanto, el 63.2% de las tiendas representan el 83% de las ventas totales.

5. Selecciona alguna columna, para este ejemplo será DIA de la SEMANA.

6. Mueve las flechas para que la “barra superior” quede en 20% y la “barra inferior” esté en 0.

7. Haz clic en el botón 80/20 para filtrar la dimensión seleccionada.

8. Analiza la nueva información.

El CUBO dejó activos únicamente los días martes y miércoles, lo cual indica que son los días que representan las menores ventas (porque el filtro aplicado fue para evaluar de 0 a 20%).

Del importe total vendido, las ventas en estos días sólo representan el 14%. También indica los rangos de venta.

Genera diferentes movimientos en la “barra de selección” para encontrar por ejemplo los mejores productos, el mejor o peor horario, etc.

Los botones que se encuentran en esta ventana funcionan de la siguiente forma:

Cómo puedes ver, la riqueza de información que obtengas dependerá del manejo de filtros que hagas, según lo que quieras encontrar, lo que busques o que intuitivamente “te lata”.

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 1 de 1

Comentarios

0 comentarios

Inicie sesión para dejar un comentario.